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Module 1

Overview and Installation

1.1 Overview

1.2 Installation

You have been provided a USB stick with all you will need for this tutorial. On
this drive is the following:

• An ICE application for your operating system

• A clone of the ICE git repository

• All tutorial documentation and slides for today

• Data files for the tutorial.

1.2.1 ICE Installation

A number of files must first be copied from the USB stick to your local machine.
Please follow the steps below:

1. Choose a location that is easy to remember and copy the correct ice-

product*.zip file for your computer’s operation system (Linux, Mac OS
X, or Windows).

2. Unzip this file to obtain the ICE application executable.
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3. Copy the git repository ice-repository.zip file to your computer.

4. Unzip this file.

1.2.2 Starting ICE for the first time

To start ICE, double-click on the application executable to open up ICE. When
the workspace chooser dialog opens, select the default workspace by clicking on
the OK button. You can enter your own directory for the workspace location,
but please make sure that it is writable and readable by you, and you remember
where it is.

When ICE opens you should see an empty Plug-in Development perspective
similar to the image below.
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1.2.3 Setting up ICE

In order to create a dashboard for your application, you will need to configure
ICE to be able to develop ICE. This Software Development Kit (SDK) version
of ICE will contain all the components necessary to generate a new instance of
ICE that will become your application’s dashboard. The first step in doing this
is to load the ICE bundles into your workspace. We have provided a developer
menu to assist in this process:

1. Select Developer → ICE → Import Local Repository

2. Using the directory dialog, navigate to the git repository you copied from
the USB drive.

3. Select Open

4. In the Search results list, select the checkbox next to the repository

5. Select Finish

This should import all the ICE bundles and you should have something like
the image below.
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At this point, you are ready to begin developing a dashboard for your appli-
cation!
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Module 2

Creating and Using an
Application Dashboard

2.1 Creating an ICE Item

This tutorial will teach you how to create your own ICE Items via the built-in
tools within ICE. To demonstrate these tools, we will walk through the devel-
opment of a dashboard for the FERN code, a fast, efficient nuclear reaction
network solver.

After creating a new ICE Item plugin project, we will demonstrate how to
provide a few lines of code to create an editor for input files for FERN. After
that we will show how a small amount of code can be used to create a job
launcher that is customized to execute FERN locally. We will also show how to
launch FERN remotely.

2.1.1 Creating the Plug-in Project

To create a new ICE Item project, navigate to File → New → Other. Open
the ICE Item Creation Wizards folder and select ICE Item Creation Wizard.
You will be met with a standard new project wizard page, in which you can
name your project. We will call ours org.eclipse.ice.fern. Once you have
named your project click the Next> button.
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The next dialog page enables you to customize the plugin-specific portions
of the project. For this tutorial, we will leave all the settings at their defaults.
Simply click Next> to move to the next page.

On this page you need to tell the wizard what you want to use as a base name
for your item classes. We will call this one Fern. Then, we will specify some
information about how the item will handle input data. FERN uses the INI file
format to specify data, so we will tell our item to use the built-in functionality
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for INI files. To do this select INI from the File Format dropdown.

When you have entered all of the required information you can click the
Finish button to generate your new ICE Item plugin project. When the project
has finished generating you should be able to explore the code that has been
created. Within the source directory there will be two packages, each containing
two Java classes:

• org.eclipse.ice.fern.launcher

– FernLauncher.java

– FernLauncherBuilder.java

• org.eclipse.ice.fern.model

– FernModel.java

– FernModelBuilder.java

To add functionality to the project we need to edit the FernLauncher and
FernModel classes.

2.1.2 Adding Functionality to the New Items

The Fern Model

The FernModel will be responsible for creating and validating input parameters
for FERN, in the form of a new FERN input file. In order to make the generated
code run there are several pieces of information that need to be changed. First,
we will need to set up the basic Item identification information. This information
is set in the setupItemInfo() method. Modify the outputName to match the
following (or something of your choosing, with a .ini file extension).

outputName = "fern_config.ini";

The String for the setName method will serve as the display name for this
Item, so set it as Fern Model. As for the String for setDescription, this will
also be used on the UI for the Item, so provide some text like the following: This
Item constructs input files for the FERN reaction network solver. The
export string will serve as the name of the action that the user can select to
write the provided data to file. Set it to something like: Export to INI. You
should now have a method that looks like this:
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@Override

protected void setupItemInfo() {

setName("Fern Model");

setDescription("This Item constructs " +

"input files for the FERN reaction " +

"network solver");

outputName = "fern_config.ini";

exportString = "Export to INI";

allowedActions.add(0, exportString);

ioFormat = "INI";

defaultFileName = "";

}

The allowedActions.add() line ensures that the export string is provided to
ICE as an allowed action, and displayed in the Item Process drop down.

With the identification information configured properly we can begin to im-
plement the Form for this FERN Model. This is done in the setupForm()
method. The generator has begun the process of implementing this method
by instantiating a Form for you to use, getting a reference to the IOService
(which provides IReader/IWriter realizations), and providing a commented out
example of how to fill out an ICE Form.

For this FERN input model, we want to add the following sections with
data entries: a network section with numSpecies, numReactions, numReaction-
Groups, massTol, fluxFrac, networkFile, rateFile data entries, an initialCondi-
tions section with T9, startTime, endTime, initialTimeStep, and density, and
an output section with a single popFile data entry. To achieve this for this
Item, we will need to add three DataComponents, one for the network section,
another for the initialConditions section, and a final one for the outputs section.
To each of those DataComponents we will add appropriate IEntry instances for
each of the data entries we have.

Add the following to your setupForm() method:

// Create the network section

DataComponent networkComp = new DataComponent();

networkComp.setName("network");

networkComp.setDescription("The parameters needed " +

"to describe the nuclear " +

"reaction network");

networkComp.setId(1);

// Create the IEntries we need for this DataComponent
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StringEntry numSpecies = new StringEntry();

numSpecies.setName("numSpecies");

numSpecies.setDescription("The number of species to

consider");

numSpecies.setDefaultValue("16");

StringEntry numReactions = new StringEntry();

numReactions.setName("numReactions");

numReactions.setDescription("The number of reactions to

consider");

numReactions.setDefaultValue("48");

StringEntry numReactionGrps = new StringEntry();

numReactionGrps.setName("numReactionsGroups");

numReactionGrps.setDescription("The number of reaction " +

"groups to consider");

numReactionGrps.setDefaultValue("19");

StringEntry massTol = new StringEntry();

massTol.setName("massTol");

massTol.setDescription("The mass tolerance to consider");

massTol.setDefaultValue("1.0e-7");

StringEntry fluxFrac = new StringEntry();

fluxFrac.setName("fluxFrac");

fluxFrac.setDescription("The flux fraction to consider");

fluxFrac.setDefaultValue(".01");

FileEntry networkFile = new FileEntry(".inp");

networkFile.setProject(project);

networkFile.setName("networkFile");

networkFile.setDescription("The network file for this

problem");

FileEntry rateFile = new FileEntry(".data");

rateFile.setProject(project);

rateFile.setName("rateFile");

rateFile.setDescription("The rate file for this problem");

networkComp.addEntry(numSpecies);

networkComp.addEntry(numReactions);

networkComp.addEntry(numReactionGrps);

networkComp.addEntry(massTol);

networkComp.addEntry(fluxFrac);

networkComp.addEntry(networkFile);

networkComp.addEntry(rateFile);
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// Create the initial conditions section

DataComponent initConditionsComp = new DataComponent();

initConditionsComp.setName("initialConditions");

initConditionsComp.setId(2);

initConditionsComp.setDescription("The parameters " +

"needed to describe the initial " +

"conditions for the problem");

StringEntry t9 = new StringEntry();

t9.setName("T9");

t9.setDescription("The temperature in Kelvin x 10^9");

t9.setDefaultValue("7.0");

StringEntry startTime = new StringEntry();

startTime.setName("startTime");

startTime.setDescription("The start time for the

simulation.");

startTime.setDefaultValue("1.0e-20");

StringEntry endTime = new StringEntry();

endTime.setName("endTime");

endTime.setDescription("The end time for the simulation");

endTime.setDefaultValue("1.0e-8");

StringEntry initialTimeStep = new StringEntry();

initialTimeStep.setName("initialTimeStep");

initialTimeStep.setDescription("The initial time step " +

"for the simulation.");

initialTimeStep.setDefaultValue("1.2345e-22");

StringEntry density = new StringEntry();

density.setName("density");

density.setDescription("The initial density.");

density.setDefaultValue("1.0e8");

initConditionsComp.addEntry(t9);

initConditionsComp.addEntry(startTime);

initConditionsComp.addEntry(endTime);

initConditionsComp.addEntry(initialTimeStep);

initConditionsComp.addEntry(density);

// Create the outputs section

DataComponent outputComp = new DataComponent();

outputComp.setName("output");

outputComp.setDescription("The parameters needed to output
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data.");

outputComp.setId(3);

StringEntry popFile = new StringEntry();

popFile.setName("popFile");

popFile.setDescription("The name of the output populations

file");

popFile.setDefaultValue("popFile.csv");

outputComp.addEntry(popFile);

// Add the components to the Form

form.addComponent(networkComp);

form.addComponent(initConditionsComp);

form.addComponent(outputComp);

Now we have a Form constructed for a typical FERN execution.

The default generated implementation of the process method is sufficient to
be able to create new FERN INI input files.

Fern Launcher

A FERN launcher handles the actual execution of the FERN application. The
generator creates the FernLauncher as a subclass of ICE’s JobLauncher, which
provides a large array of features and functionality. As a subclass of JobLauncher,
the FernLauncher enables users to execute FERN locally or remotely. To do so,
we just need to add a small amount of code that customizes the ICE job launch-
ing capabilities for FERN.

The first bit of code to add to the FernLauncher specifies the name of the
actual Fern executable. In the setupItemInfo() method, set the execCommand
to the following:

execCommand = "${installDir}fern-exec";

This tells ICE that the FERN executable is called fern-exec, and to set the
overall execution command to it’s install path plus the executable name. The
installDir flag will tell ICE to insert the user-specified executable location (pro-
vided through the graphical form editor’) into the execCommand, with a trailing
OS-specific path separator. This install directory is specified through the Hosts
Table on the editory.
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We also need to inform the JobLauncher what other files are involved in this
execution. To do that, the JobLauncher provides an addInputType() method.
Add the following to setupForm():

addInputType("Network File", "networkFile",

"Network File Description", ".inp");

addInputType("Rate File", "rateFile", "

Rate File Description", ".data");

And that should be it. The generator has taken care of everything else for
us. We are now ready to launch ICE with our FERN plugin, and use the FERN
Items we have just created.

2.2 Using the Application Dashboard

In order to use the functionality you’ve added to ICE, it is necessary to start
a new instance of ICE, called the runtime instance. This will be a completely
new copy of ICE that has your new plugins activated. This new instance is how
you and your users will typically interact with your application. Once you are
satisfied with the functionality you have added, you can create a new runtime

application that can be deployed to users. Creating runtime applications is
beyond the scope of this tutorial.

2.2.1 Launching a New ICE Instance

From the Developer top-level menu, select ICE → Launch New Instance. This
will display a dialog asking you which new plugins you’d like to include as part
of the new ICE instance.
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Select org.eclipse.ice.fern (or whatever name you chose for your plugins)
and click OK. This will create and launch a new instance of ICE that includes
your custom plugins.

2.2.2 Importing a Project

This section will show you how to import existing FERN application source
code and executables into the ICE instance so that you can use it with the
dashboard you have just created. The steps are as follows:

1. With a new ICE instance open, close the Welcome view if necessary

2. Go to Package Explorer view, right click and select New → Synchronized

C/C++ Project
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3. Enter fern for the Project name:

4. Click the New... button next to the Please select a connection drop-
down
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5. Enter gordon for the Connection name

6. Enter gordon.sdsc.edu for the Host

7. Enter your training username for the User

8. Click on the Password based authentication button

9. Enter the training account password

10. Click Finish

11. Click on the Browse... button

12. Select fern from the directory browser and press OK
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13. From the Project type section, open Makefile project and choose
Empty Project

14. Click Finish

At this point you should see a fern project in the Project Explorer view.
After a few moments it should complete the synchronization and when you open
the project you will see it contains a variety of files.

2.2.3 Building a Project (Optional)

We have provided a pre-built executable in the build subdirectory for the pur-
poses of this tutorial. However if you wish to build FERN yourself, you can
proceed as follows:

1. Right click on the project and select Properties

2. Click on the C/C++ Build entry

3. Append build to the end of the Build directory entry

4. Click OK

5. Click on the hammer icon in the toolbar
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2.2.4 Creating an Input File For Your Application

To use ICE to create an input file, you first need to instantiate the FernModel

you created previously. To do this, right click on the fern project (the project
in which you want the input file to be located), then choose New → Other,
select the Create Item Wizard, then click on Next>.

Selecting the FernModel Item, then click Finish, and you will be presented
with the view in the figure below.
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Here you can modify the various defaults with the values you would like for
a given Fern simulation. Once done, simply save the Item and click the Go!

button. This will execute the process of creating a new INI Fern input file
for use with the Fern Launcher. You can check the result by opening the
fern config.ini file, as shown below.

2.2.5 Creating a Local Launcher

Now you can similarly create a new FERN launcher. Note that as FERN is not
installed locally, we will not acutally launch the program using this method.

After creating the Launcher, you should see a view like below.
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To configure a launch, simply set the correct input file, along with its dependent
network and rate files.

At this point, if you had FERN built on your local machine, or if you had
it built on some remote host, you could configure that in the Hosts table. ICE
would then execute FERN based on that input.

After the execution you should see the results in the Console, as shown
below.

The execution should have produced a CSV file with the computed populations.
You can double-click that file to view them graphically in the ICE Plot Editor.
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2.2.6 Creating a Remote Launcher

Launching FERN remotely involves creating a Parallel launch configuration.
This procedure is not yet integrated with the ICE launcher, but will be available
in the next release of ICE.

A Parallel launch configuration for your application is created as follows:

1. Select the Run → Run Configurations... menu

2. Click on the Parallel Application entry, then click the New button

3. From the Target System Configuration dropdown, select Generic Torque

Batch

4. From the Please select a connection, choose the gordon connection
you created earlier

5. Click Yes when asked if you would like to run a command on the remote
system (optionally check the box to not ask again)

6. After a few seconds, you should see the job submission form

7. Select normal for the queue
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8. Switch to the Application tab

9. If the project field doesn’t contain anything, click Browse and choose the
fern project

10. Click Browse next to the Application program field, open the build

directory, select fern-exec, then click OK
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11. Switch to the Arguments tab and enter the name of the outputfile you
chose in the FernModel file

12. Uncheck Use default working directory, click on the Browse button,
select the fern directory in the browser and click OK

13. Click Run to submit the job

During the job submission, you will be asked if you would like to switch to
the System Monitoring perspecive. Click Yes to see this feature. The image
below shows a typical instance of this perspective in action.
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Click on the Inactive Jobs view and scroll to the bottom. You should see
a job from your username that is either submitted or completed. When the job
is completed, you can switch back to the C/C++ Perspective.

In the Project Explorer view, click on the synchronize button to copy the
output files back to your local machine.
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If the project is not already open, you can open it now and you should see
the resulting CSV file. Double click on this file to launch the CSV viewer.
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Module 3

Adding Visualization to
your Application

Resource Components are ICE Components which contain a grid of visualization
resources. These resources can display files from a variety of sources, such as
CSV files or VisIt visualizations. Geometry and Mesh editors allow for editing
of shapes or meshes. All three can be added to an Item to offer visualization of
data.

3.1 Prerequisites

You will need access to an installation of VisIt version 2.9.2. There is a copy of
the software in the VisIt folder of your USB drive. Windows users should open
the Windows installer, while users of other OSs can just copy the appropriate
folder onto their machine.

3.2 Adding the Components

We will be adding the visualization components to the model made in the pre-
vious section, so return to your original ICE window, closing the launched in-
stance. For convenience, you can copy and paste the code from the XSEDEVi-
sualizationeModel.java in the org.eclipse.ice.demo.visualization.model package.
Its location can be seen in figure 3.1.

First, copy and paste the following example code into the end of your Item’s
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Figure 3.1: The package structure for org.eclipe.ice.demo bundle

setupForm() method. You can also find this code in XSEDEVisualization-
Model’s setupForm() method, but be sure to note the comments specifying
where to begin and end copying.

//Create the resource component

ResourceComponent resourceComponent = new ResourceComponent();

//Set the component’s data members

resourceComponent.setName("Resource Component");

resourceComponent.setDescription("Results");

resourceComponent.setId(1);

//Declare the files and resources

VizResource csvResource = null;

VizResource visItResource = null;

IFile csvFile = null;

IFile visItFile = null;

//If the file was found, create the CSV resource and add it to the component

try{

//Open the files

csvFile = ResourcesPlugin.getWorkspace().getRoot().getProject("itemDB").getFile("fib8.csv");

visItFile = ResourcesPlugin.getWorkspace().getRoot().getProject("itemDB").getFile("tire.silo");
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//If the file was found, create the CSV resource and add it to the component.

if(csvFile.exists()){

csvResource = new

VizResource(csvFile.getLocation()

.toFile());

resourceComponent.addResource(csvResource);

}

//If the file was found, create the VisIt resource and add it to

//the component

if(visItFile.exists()){

visItResource = new

VizResource(visItFile.getLocation()

.toFile());

resourceComponent.addResource(visItResource);

}

}

catch(IOException e){

e.printStackTrace();

}

//Create the geometry component

ShapeController geometryRoot = new ShapeController(new

Shape(), new BasicView());

GeometryComponent geometryComponent = new

GeometryComponent();

geometryComponent.setGeometry(geometryRoot);

geometryComponent.setName("Geometry Editor");

//Create mesh component

MeshComponent meshComponent = new MeshComponent();

meshComponent.setName("Mesh Editor");

//Add the components to the form

form.addComponent(resourceComponent);

form.addComponent(geometryComponent);

form.addComponent(meshComponent);

// Set the context on the Form

form.setContext("visualization");

This will cause errors in your file. To resolve them, first open the MANI-
FEST.MF file in your project’s META-INF folder, switch to the Dependencies

tab, and click the Add button under the Imported Packages section, both high-
lightted in figure 3.2. Select org.eclipse.eavp.viz.datastructures, press
OK, and save the file. You can then return to your model file, hover over the un-
derlined code for each of the errors until a menu pops up, and select the option
to add a package to the imported packages, as seen in figure 3.3. Repeat the

30



process, this time choosing the option to import the class. Save the file when
the hover menu no longer appears over errors.

Figure 3.2: The Manifest dependencies view

Figure 3.3: The menu displayed when hovering the mouse over code with an
error.

This code will add a Resource Component, Geometry Component, and Mesh
Component to your Item and load tire.silo into the Resource Component. When
done, launch ICE again, using Developer rightarrow ICE rightarrow Launch

New Instance.
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3.3 Using the Resource Component

ICE uses an instance of VisIt, a visualization code from Lawrence Livermore
National Laboratory, running in another process for visualization. ICE can
also use ParaView, but this tutorial will only cover VisIt, as the processes for
conencting to ParaView and using a ParaView Plot Editor are largely similiar
to those for VisIt.

3.3.1 Establishing a VisIt Connection

In order to visualize resources containing VisIt files, ICE must be connected
to a running VisIt installation. To set up this connection, select Windows →
Preferences... in ICE’s menu bar. (On Mac OS X, Preferences is instead
located under ICE in the menu bar.)

Figure 3.4: The ICE Preferences Menu for Windows and Linux. It will be
located under ICE instead of Window on Mac.

Select Visualization→ VisIt in the tree on the left side of the Preferences
window.

Press the button with a ”+” symbol in the upper right of the Preferences

Menu (highlighted in Figure 3.5) to add a new row to the table. Click on the
Path cell of the new row and put the path of your installation of VisIt.

For example, on Windows, if assuming a username of ”username”, and VisIt
was installed in the default location, the path will be:

C:\Users\username\AppData\Local\Programs\LLNL\VisIt 2.9.2.
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Figure 3.5: The VisIt preferences page in the Preferences dialog. The hi-
lighted button will add a row for a new connection to the table.

On Linux, the path will be based on where you extracted the visit2 9 2.linux-
x86 folder, ending with /visit2 9 2.linux-x86 64. If you unzipped it to the desk-
top, it will be:

/home/username/Desktop/visit2 9 2.linux-x86 64

On Mac OS, the path will be based on the location you put the Visit appli-
cation. If placed in the Applications folder it will be

/Applications

Press Apply, then OK, both in the lower right hand corner of the Preferences
Menu. ICE will now open and connect to this VisIt installation each time ICE
is opened.
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3.3.2 Opening Your Item

Before opening your new Item, select the itemDB folder in the Project Explorer

and press the import button, highlighted below.

Figure 3.6: ICE’s import button.

Select the files you want to visualize and click OK. For the tutorial, this
should be the tire.silo file from the Fern synchronized project directory. You
should now see the file within the itemDB folder.

Select File → New → Other... from the toolbar. In the new dialog, select
the Create Item Wizard and hit Next. Then select Visualization Model and
press Finish. You can also select the Visualization Model (Pre-completed)

if you skipped the first part of the tutorial.

Finally, switch to the ICE Perspective to ensure that the necessary Views
will be open. To do this, click the Open Perspective button in the upper right
of the workbench screen.

In the dialog, select ICE and press OK.

3.3.3 Managing the Resources

Your Item should look like this when it loads.
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Figure 3.7: ICE’s Open Perspective button.

Figure 3.8: The Visualization Model after it is initially opened. Hilighted in
the lower left are the tabs for the three components, the Geometry Editor, the
Mesh Editor, and the Resource Component.

In the lower left of the Visualization Model are three tabs, hilighted in
Figure 3.8. Switch to the Resource Component tab in your Item and to the
Resources tab on the left, as shown below.

Double click on the file named tire.silo to load it into the Resource Compo-
nent.

At the top left of the Visualization Model will be controls for the compo-
nent’s layout.

The Clear button will close all plots in the component. The other two
controls will allow you to specify the number of rows and columns in the grid.
Be careful when reducing them, as any plots which no longer fit in the grid will
be closed.
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Figure 3.9: The ICE Perspective’s Resources tab.

Figure 3.10: The layout controls for the Resource Component.

If you hover over a plot, a button will appear in its upper left hand corner.
Clicking it will close that plot.

Figure 3.11: The X button in the upper left will close the plot.

3.3.4 Interacting with VisIt Plots

A VisIt plot will contain a 3D visualization of some model. You can click and
drag within the plot to rotate the image and zoom by scrolling your mouse
wheel. Right clicking in the plot will open a context menu, providing options
for how the model will be displayed.
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Figure 3.12: An example of a file open in VisIt displayed in a Plot Editor.

At the bottom of the plot will be a series of controls for animation. If your
plot does not have time series data, they will be greyed out.

Figure 3.13: The Plot Editor’s animation controls.

The plot can be set to display an arbitrary time step by either dragging the
slider or by typing a time into the box to its left.

3.3.5 Editing 3D Structures

ICE also contains capabilities to render graphics with the Geometry Editor and
Mesh Editor. Programatically populating these editors with custom input is
beyond the scope of this tutorial. However, what follows will be a brief overview
of the editors’ functionality.

The Geometry Editor

Now switch to the Geometry Editor tab in you the Visualization Model and
the Shapes tab on the left.
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Clicking the Add Primitives button will display a drop down of primitive
shapes which can be added to the scene.

Figure 3.14: The Add Primitives button displays a menu of shapes to add.

Complex shapes can similarly be added using the Add Complex button.

Figure 3.15: The Add Complex button can add a Union of shapes.

Primitive shapes can be added under complex shapes by selecting anything
beneath the desired parent complex shape before adding the new primitive.

The three other buttons are responsible for creating copies of or removing
selected shapes from the tree.

The Transformation View, in the lower left of the workbench screen, has
spaces to set the rotation, scale, and translation of a selected object.
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Figure 3.16: An example of a constructive solid geometry tree in the Shapes

tab. Adding shapes with the highlighted leaf selected will cause them to become
children of Union 1.

Figure 3.17: The Transformation View.

The Mesh Editor

Now switch to the Mesh Editor tab in your Item and Mesh Elements tab on
your left.

Clicking within the grid will create a vertex, until the fourth completes the
polygon.

Click again to make the polygon permanent, signified by turning purple, or
hit Esc to cancel.

The Mode button in the top left allows you to switch between Add Elements

mode, used previously, and Edit Elements mode.

In edit mode, you can click a vertex (or vertices) to select them.

You can click and drag a vertex to move all selected vertices around the grid.

39



Figure 3.18: A new polygon, colored green because the user has not yet perma-
nently added it to the mesh.

Figure 3.19: The polygon turns purple after clicking, showing that it has been
finished.

Figure 3.20: The Mode button allows switching between Edit Elements mode
and Add Elements mode.
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Figure 3.21: A selected vertex will turn blue.

3.4 Further Reading

This tutorial has only given a brief overview of the ways in which you can use
ICE’s visualization tools. For more detailed information, look under the docs

folder in the ICE repository. The visualization folder contains a tutorial on the
CSV and VisIt plots, while the geometryEditor and meshEditor folders have
tutorials on the geometry and mesh editors, respectively.
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Module 4

Exploring Visualization in
ICE

4.1 Geometry Editor

This article is designed to outline the basic controls of ICE’s Geometry Editor.

4.1.1 Getting Started

Once ICE is installed on your computer, there are no further dependencies or
preparation required to use the Geometry Editor.

4.1.2 Opening a Geometry Editor

To open a Geometry Editor in ICE, you have three options:
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Top to bottom, they are:

1) Click the File menu, then New, then Other. . . and select the Create Item
Wizard in the new dialog and press Next. Then, select Geometry Editor from
the list and press Finish.

2) Click the New button. Select Create Item Wizard in the new dialog and
press Next. Then, select Geometry Editor from the list and press Finish.

3) Enter the ICE Perspective by clicking the Open Perspective button in the
upper right corner of the screen, select ICE from the dialog that pops up, and
click OK. Afterwards, click the Create an Item button, select Geometry Editor,
and click OK.

4.1.3 Working with the Geometry Editor

Camera

You can change the perspective of the camera by clicking and dragging inside
the Geometry Editor. You can see this initially by the way the three axes and
the reference plane move as you rotate the camera about the origin. If you
hold shift while dragging, you will instead move the central point the camera
is focused on. If you hold ctrl, you can drag the mouse up or down to zoom in
or out, respectively. Scrolling the mouse wheel offers another way to zoom the
camera.

Primitive Shapes

Simple shapes can be added with the Add Primitives dropdown menu in the
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Shapes view. Simply select an object from the menu to add it to the scene.

Clicking on the shape’s name in the Shapes View will cause that shape to
turn red in the editor.

Selections in the Shapes View also activate the Transformation View in the
lower left corner. Editing the values in this view will change the selected shape
accordingly.
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Size - Controls the overall size of the shape. Setting size to X is equivalent
to setting the shape’s three scales to X times their current value.

Translate - Controls the position of the shape. Setting one of the transla-
tions will move the shape that many units along the given axis.
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Rotation - Controls the orientation of the shape. Setting one of the rota-
tions will rotate the shape the given number of degrees about that axis.

Scale - Controls the size of the shape in three directions. Setting one of
the scales will stretch or compress the shape in that direction by a factor of the
scale’s new setting.

Complex Shapes

Multiple primitive shapes can be combined within a single grouping for easier
editing. First, create a complex shape using the Add Complex button.
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Currently, only unions are supported. The union will appear in the Shapes
View with an empty spot for a child shape.

Select <Add Shape>and add a primitive shape as before to add the shape
as a child of the union. To add additional shapes, select the child shape and
add another as normal.

Selecting the union will select all of its child shapes, and changes to the
transformation view will affect the entire complex shape. Individual shapes can
still be selected for editing on their own.

You can add a complex shape as a child to a complex shape in the same way
as a primitive shape, allowing for nested unions
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Copying

Once you have a shape created, you can automatically create copies of that
shape.

Press the Duplicate Shape button, highlighted above, to create an exact copy
of the selected primitive shape. The copy will appear as the child of the same
complex shape as the original, if any, and can be modified independently after
creation.
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You can systematically create many copies of a shape with the Replicate
Shape button highlighted above. This will open a new dialog.

The quantity is the number of desired copies of the shape which should be
in the replication. This includes the original (ie setting quantity to 2 will result
in 2 shapes, the original and a copy).

The Shift boxes allow you to specify an offset to be placed between each
copy. For example, if you set X to 100 and Y to 50, then each copy will be 100
units along the X axis and 50 along the Y away from the previous copy.

The original shape and all copies will be placed in a new complex shape,
which will take the original shape’s position in the tree.

Deletion

You may remove a shape and all its children by selecting it in the Shapes view
and clicking the Delete button, highlighted below.
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Saving

You may save the contents of the Geometry Editor. This can be done as normal
for an Eclipse file, using the Save button or Ctrl + S. The result will be a file
named Geometry Editor.xml in the ItemDB folder. The Geometry Editor can
be reponed by double clicking on this file.

4.2 Editing Meshes

This document is designed to outline the basic user controls of the Mesh Editor
plugin in ICE.

4.2.1 Getting Started

Once ICE is installed on your system, there are no addional dependencies or
preparation required to use the Mesh Editor.

Opening a Mesh Editor

To open a Mesh Editor in ICE, you have four options:
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The UI elements which can be used to open a Mesh Editor are highlighted.
Instruction for how to use each one, from top to bottom, left to right, are given
below.

1) Click the File menu, then New, then Other. . . and select the Create Item
Wizard in the new dialog and press Next. Then, select Mesh Editor from the
list and press Finish.

2) Click the New button, select Create Item Wizard in the new dialog and
press Next. Then, select Mesh Editor from the list and press Finish.

3) Click the Mesh Editor button.

4) Enter the ICE Perspective by clicking the Open Perspective button in the
upper right corner of the screen, select ICE from the dialog that pops up, and
click OK. Afterwards, click the Create an Item button, select Mesh Editor, and
click OK.

4.2.2 Working With the Mesh Editor

The mesh editor will initially open to an empty grid, as shown below. There
is currently no way to import pre-existing meshes from another source directly
into the Mesh Editor.
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Navigation

Meshes are constructed on the background grid. Gridlines are spaced one unit
apart from each other. The origin is the initial center of the screen with the x
axis in red and the y axis in green coming out from it in the positive x and y
directions, respectively.

Camera Controls

The camera is controlled with keyboard and mouse commands. The W, A, S,
and D keys are used to move the camera around the editor’s area, while scrolling
the mouse wheel is used to zoom the camera in and out.

If the controls are not working, ensure that the Mesh Editor has focus by
clicking inside of it.

Camera Controls
Action Key(s)
Scroll Up W or Up Arrow
Scroll Down S or Left Arrow
Scroll Left A or Right Arrow
Scroll Right D or Down Arrow
Zoom In Scroll mouse wheel up
Zoom out Scroll mouse wheel down
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Adding Elements

2D meshes are constructed in the editor by specifying one quadrilateral at a
time. To add a new polygon, the Mesh Editor must be in Add Elements Mode.
This mode is the editor’s default setting, and it can later be reset by clicking
the Mode button in the top left corner.

Placing Vertices

In Add Elements Mode, clicking anywhere on the grid will place a new vertex
at that location. These new, temporary vertices and the edges between them
will be colored in green, to show that the polygon is still under construction.

Alternatively, you may select a vertex not already in the new polygon. This
allows you to reuse vertices and/or edges already present in the mesh to form
part of your new polygon.

Once the fourth vertex has been specified, the polygon will be displayed
in full. Clicking one more time will change it to purple to show that it has
been completed. At any time before this, you can press the backspace, delete,
or escape buttons to cancel the new polygon, removing it from the editor and
allowing you to start the process over.

Editing Elements

To edit an already present element of the mesh, you must switch to Edit Ele-
ments Mode. The Mode button in the upper left corner allows you to switch
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Figure 4.1: One of the edges from the trapezoid is being combined with a new
edge in the creation of the current polygon.

between modes, as shown below.

A vertex can be selected by either clicking it in the Mesh Editor, or by
selecting it from the tree in the ICE Perspective’s Mesh Elements View. Holding
down shift while clicking will allow multiple vertices to be selected at once, while
holding down control during a click will toggle a vertex’s state either into or out
of the selection. Selected elements are displayed in blue. The current selection
can be cleared by pressing the backspace, delete, or escape buttons.
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Figure 4.2: Two vertices are selected. When the bottom vertex is moved left,
the top vertex is moved left by an equal amount.

Click on a selected vertex and drag it to change its location. The clicked
vertex will stay beneath your mouse cursor, while all other selected vertices will
be moved as well, keeping their relative position to the dragged vertex. White
circles are displayed to show each vertex’s new location. Pressing backspace,
delete, or escape during the drag will deselect the vertices and cancel the move-
ment.

Edit Mode Controls
Action Key(s)
Select vertex Left click
Add to selection Shift + left click
Toggle (Add/Remove) Selection Ctrl + left click
Move selected vertices Left click on vertex and drag mouse
Clear selection/Cancel move Backspace, Delete, or Escape
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Alternatively, you can edit a vertex more precisely by setting its exact co-
ordinates. First, select it in the Mesh Elements View, then open the Properties
View. The vertex’s x and y coordinates will be displayed in editable text boxes.

Selecting a polygon in the same way, then opening the tab for one of its
edges in the Properties View, will display the edge’s boundary conditions for
that polygon. These are editable, just like the vertices are.

Deleting Elements

Polygons in the mesh can be deleted. All four vertices for the polygon must be
selected, then press the Delete button on the toolbar. Vertices and edges which
are still part of other, undeleted, polygons will remain, but all others will be
removed from the editor.

Additional Controls

The Toggle Axis button on the toolbar will show/hide the axes in the editor.
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The Toggle HUD button will remove or display the small info bar beneath
the editor which shows the current cursor and camera positions.

Saving

You may save the contents of the Mesh Editor. This can be done as normal for
an Eclipse file, using the Save button or Ctrl + S. The result will be a file named
Mesh Editor.xml in the ItemDB folder. The Mesh Editor can be reponed by
double clicking on this file.

4.3 Visualization Tools

Currently, ICE features two plugins for visualizing and plotting simulation out-
put data:

VisIt Tools - An interactive visualization tool for rendering data defined
on 2D and 3D meshes.

CSV Plotting Tools - A customizable, 2D data plotting utility for data in
CSV format.

The CSV Plotting Tools require no additional software or preparation before
use. The VisIt Tools need both a VisIt installation and a connection between
ICE and a VisIt session.

57



4.3.1 VisIt Installation

Before preparing ICE, VisIt must be downloaded and installed. The ICE de-
velopment team recommends using the latest working version of VisIt (2.9.2)
but acknowledges that any version greater than or equal to 2.8.2 should work.
The latest VisIt version, 2.10, is not currently compatible with ICE. VisIt does
not need to be installed on the same machine where ICE is installed since ICE
is capable of launching a VisIt session on a remote machine. Regardless of the
host, make note of the directory where VisIt is installed as it will be necessary
in the next step.

Configuring the VisIt Connection

Once VisIt is installed, ICE must connect to a running instance of VisIt in order
to make use of its rendering capabilities. ICE provides two different tools that
utilize VisIt, the Plot Editor and the Visualization Perspective. Both utilities
provide slightly different functionality and are accessed through different means.

Connecting for the Plot Editor

The Plot Editor uses a default connection to VisIt established in the ICE Pref-
erences page. This process only needs to be performed once. After initially
creating the connection, ICE will launch and connect with VisIt upon each
subsequent launch of ICE.

To set the connection, select Window → Preferences. . . in ICE’s menu bar.
(On Mac OS X, Preferences. . . is instead located under ICE in the menu bar.)
Select Visualization → VisIt in the tree on the left side of the Preferences win-
dow.
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Press the button with a ”+” symbol in the upper right (highlighted in the
image above) to add a new row to the table. Click on cells in the new row to
edit their values. The default values automatically supplied by ICE should be
appropriate for most users. However, two fields may need to be changed:

Host: The default value of ”localhost” allows for connections to VisIt in-
stallations on the same machine where ICE is running. To launch a remote
VisIt connection, change this to the hostname of that machine.

Path: Enter the full path to the directory containing the VisIt executable,
not the executable itself. The VisIt executable is named visit on Linux and Mac
OS X. On Windows, VisIt.exe is the appropriate file.

Once finished editing the cells in the new row, press Apply, then OK. ICE
will then launch an instance of VisIt and connect to it.
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Connecting for the Visualization Perspective

To establish a VisIt connection in the Visualization perspective, begin by open-
ing this utility. In the main menu bar at the top of the window, select Window
→ Perspective→ Open Perspective→ Other. . . . Select Visualization in the di-
alog that appears and click OK. Alternatively, the same dialog may be accessed
by clicking the Open Perspective button in the toolbar in the upper right-hand
corner of the ICE workbench.

Click the Launch VisIt button in the tool bar to enter the VisIt connection
parameters.

The resulting dialog offers three options for connecting to VisIt.
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1) Launch VisIt locally - This connection option will launch a new VisIt
session on the machine running ICE. If VisIt in installed on this machine, use the
Browse button to enter the directory containing the VisIt executable into the
Path to VisIt field. Optionally, set a port number (default 9600) that VisIt will
use to serve data to ICE, and if this VisIt session will be shared with multiple
users, set a password.

2) Launch VisIt remotely - Using this method of connecting will launch
a new VisIt session on a machine other than the one used to run ICE. Specify
the hostname and full path to the directory containing the VisIt executable.
Optionally, enter a port number (default 9600), and if VisIt session will be
shared with multiple users, enter a password. If access to the remote machine
where VisIt is installed requires the use of an external gateway or proxy, specify
its URL and port number, as well.

3) Connect to VisIt - To connect to a previously launched VisIt session,
specify the hostname, port number, and password set on the lanuch of that
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session. This information will need to be obtained from the person who initially
launched the VisIt session. If access to the machine hosting the VisIt session
requires the use of an external gateway or proxy, enter its URL and port number,
as well.

For a reminder of where VisIt is installed on Windows, find a shortcut to
VisIt on the desktop or in the start menu. Right-click the shortcut and open
its Properties. The path to the VisIt executable’s directoy will be shown next
to Target.

Regardless of the method used to connect to VisIt, enter a Connection name
at the bottom of the dialog.

When connecting to an existing session, specify a Window ID between 1
and 16. The Window ID used determines how ICE will connect to VisIt. If
multiple users connect using the same Window ID, they will all see and be able
to interact with the same VisIt view. However, if multiple users wish to each
have their own unique session with its own controls, assign a unique Window
ID to each user. The VisIt installation can support up to 16 unique window IDs
at a time.

Once the required fields are complete, click the Finish button at the bottom,
and ICE should begin connecting to VisIt.

4.4 Using VisIt

4.4.1 Opening a Plot Editor

To open a Plot Editor, a file that uses this editor must first be placed in the
Project Explorer. This view lists files imported into ICE. To access the Project
Explorer, use the the menu bar at the top of the window and navigate to Window
→ Show View → Project Explorer. Depending on the active Eclipse perspec-
tive, opening this view may require selecting Other. . . and finding the Project
Explorer in the dialog under the General category in the tree.

By default, the Project Explorer should automatically import the ICE-
Files/default and ICEFiles/itemDB folders. If it does not, or if you want to
import a different folder into ICE, right click in the Project Explorer and select
Import. . . from the context menu. Then, select General→ File System from the
tree, and press the Next button. Select directories and/or files to import into
the Project Explorer, and enter which folder they should be imported into, as
shown below.
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Once a file is in the Project Explorer, simply double click on it to open it in
VisIt.
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4.4.2 Opening a file in the Visualization Perspective

To open a file in the Visualization Perspective, first import the file into the
Visualization File Viewer, located in the upper left of the screen. Click the
Open a File button (green plus sign icon). The resulting dialog allows for the
selection of local files to import.

Currently, ICE can only open files in VisIt on the same machine that is
running the VisIt session. For a connection to a remote VisIt installation, click
the arrow beside the Open a File button, and select “Add a remote file” from
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the drop down menu. The resulting dialog box allows the user to browse the
file system of the remote machine hosting the VisIt session.

Once a file is in the Visualization File Viewer, create a plot by selecting the
file, and then clicking the Add a Plot to the List button located in the VisIt
Plot Viewer in the lower part of the column on the left side of the workbench.
The resulting dialog allows the user to select plots from the file to view. After
making a selection or selctions and pressing OK, these plots will be placed in
the VisIt Plot Viewer.

Finally, double click a plot in the VisIt Plot Viewer to render the data to
the screen.

Both the Plot Editor and the Visualization Perspective allow the user to
rotate the model by clicking and dragging inside the display area or adjust the
zoom by scrolling the mouse wheel. Other commands vary slightly between the
two utilities.
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4.4.3 Selecting the Plot

In the Plot Editor, pressing the Select Series. . . button will open a dialog which
lists the various plots in the opened file. Simply select one and click OK to open
it.

In the Visualization Perspective, the opened plots will be listed in the VisIt
Plot Viewer. Double click on one to open it.

4.4.4 Setting the Plot Representation

VisIt is capable of displaying plots in several different representations, such as
pseudocolor, contour, or volume.

To switch between plot types in the Plot Editor, right click inside the display
area and select one of the listed options under the Representation category in
the context menu.

The Visualization Perspective features a drop down menu at the top of the
VisIt Plot Viewer which allows for switching between the available representa-
tions.
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4.4.5 Animation and Time Data

The Plot Editor features a time slider widget at the bottom of the screen.

The controls, in order of left to right, are:

1) Return to the previous time step.

2) Automatically play the plot as an animation by displaying the time steps
sequentially.

3) Advance to the next time step.

4) Opens an options menu that allows the user to set the playback speed,
toggle whether the animation should loop when it reaches the end, and set the
plot to the first or last time step.

5) A display for the current time step. It can be edited to set the plot to an
arbitrary time step.

6) A slider that shows the current time step’s position on the timeline. The
slider can be dragged around the timeline, setting the plot’s time step accord-
ingly.

In the Visualization Perspective, the Visit Plot Viewer has a similiar set of
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controls.

The buttons, in order of left to right, are:

1) Return to the previous time step.

2) Automatically play the plot as an animation backwards, going through
the time steps in reverse order.

3) Pause the animation.

4) Automatically play the plot as an animation by displaying the time steps
sequentially.

5) Advance to the next time step.

4.4.6 Sending VisIt Python Commands

This functionality is only available in the Visualization Perspective.

The Execute Python Script button in the upper right of the VisIt Plot Viewer
will open a new window with a Python shell. Commands entered into this shell
will be sent to the instance of VisIt.
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Python code can be written into the shell directly, but the Load from File
button will import an existing .py script into the console. Once done, hit the
Execute button to send the python command(s) to VisIt.

Writing Python scripts for VisIt is beyond the scope of this tutorial. Please
refer to the VisIt Python Interface Manual provided by the VisIt development
team at Lawrence Livermore National Laboratory for information on Python
commands for VisIt.

4.5 Using the CSV Plot Viewer

ICE offers functionality for the viewing of CSV files.

4.5.1 Opening a CSV File

CSV files are opened in Plot Editors through the Project Explorer. Open the
Project Explorer with Window → Show View → Project Explorer and import
the file by right clicking and selecting import. Once the file is in the Project
Explorer, double click to open it.

ICE expects CSV files to be in an [m x n] format, with no row holding empty
values. The first row in the file will be used to name a series, with the series
data being specified by the column of values beneath it.
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4.5.2 Using the CSV Plot Viewer

Controlling the Graphics

The row of buttons at the top of the viewer provide basic graph editing capa-
bilities.

The first button allows the user to edit a variety of basic graph attributes,
such as font, axis titles and scales, line colors, etc.

The next two buttons allow for the addition and removal of annotations for
specific data points.

The central grouping of buttons allow the user to zoom and pan the camera
in a variety of ways.

The two yellow arrow buttons will undo/redo changes made to the graph.

The final button will export a screenshot of the graph.
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Setting the Independent Series

By default, the first column in the file will serve as the independent series
setting the graph’s x axis. By right clicking the Plot Viewer and selecting Set
Independent Series. . . , the user can set the independent series to any other series
in the file.

Setting the Dependent Series

When first opened, only the series defined by the second column in the file will
be displayed. There are several ways to change this.

The Select series. . . button in the upper left hand corner will display a list
of all the series in the file. Selecting one and pressing OK will graph that series
and removing all others.

Right clicking and choosing Select series. . . from the context menu will open
a dialog in which any of the available series may be selected. All selected series
will be graphed at once with deselected series removed.

Finally, the Remove all series option in the context menu will completely
clear the graph.

Viewing the Data

At the bottom of the editor is a series of tabs.
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The Plot tab contains the graph described thus far. The Data tab will
display the raw numerical source data in a text editor.
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Module 5

Extending ICE

5.1 Scripting with EASE

In addition to interacting with tools via the ICE user interface, ICE also provides
a scripting framework based on the Eclipse Advanced Scripting Environment
(EASE).

5.1.1 PyDev Installation (optional)

Although it is possible to edit Python scripts in Eclipse using the default text
editor, however it is much more productive to use the PyDev Eclipse develop-
ment environment if you are planning to do a lot of script development. In
addition to the usual syntax coloring and other advanced editing features you’d
expect in Eclipse, PyDev also provides the ability to run and debug Python
programs from within the Eclipse environment.

PyDev can be easily installed from using the Eclipse Marketplace client as
follows. From the ICE menu bar, select Help → Eclipse Marketplace...,
type “pydev” in the Find field, then click the Go button. After a few seconds,
you should see an entry for PyDev as shown in image below. Simply click the
Install button and follow the prompts to install the feature. Once Eclipse has
been restarted, any Python scripts ending in “.py” will be recognized by PyDev
and opened in the Python editor by default.
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5.1.2 EASE Configuration

There are a number of configuration settings that can be used to customize the
behavior of EASE. These configuration settings are accessed via the Scripting

preference page in the Eclipse preferences. To open the Scripting preference
page, select Window → Preferences... in the ICE menu bar. (On Mac OS
X, Preferences. . . is instead located under Eclipse ICE in the menu bar.) Open
the Scripting tree item on the left side of the preferences window and you will
see the different preferences that can be configured.

EASE works best if you keep your scripts in one or more projects in your
workspace. You can then associate these Script Locations so that EASE knows
they are used for managing your scripts. You can either use an existing project,
or create a new project for the scripts. In this tutorial, we’re going to use the
existing fern project to store our scripts, but you could just as easily create
a new one. To configure the projects, select the Script Locations preference
item to reveal the dialog shown below. You can then use the Add Workspace...

button to select one or more projects from the workspace. For this tutorial,
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choose the fern project.

By default, EASE is configured to use the JavaScript (Rhino) engine. Since
this tutorial assumes that the preferred environment is Python, we recommend
changing this default. To set the script engine default, select the Shell prefer-
ence item. Next, select Python (Jython) from the Preferred Engine: drop-
down as shown below, then click on OK.
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5.1.3 Creating and Running Scripts

There is nothing special about creating and running EASE scripts. They can be
created in a variety of ways using the development tools available in ICE, and
then run later when needed. For this tutorial, we will be creating the scripts
using PyDev (or any text editor) and running them directly using the Run As

→ EASE Script context menu.

EASE also provides a perspective for creating, managing, debugging, and
running scripts called the Scripting perspective. This perspective contains
views for running script commands interactively, and for exploring script mod-
ules. To switch to the Scripting perspective use the Perspective Switcher

icon or select the Window → Perspective → Open Perspective → Other...

menu, then select Scripting from the list. You should see the perspective shown
below.

EASE hides many of the details that would normally be required to ma-
nipulate Java objects and perform actions in the Eclipse IDE. It does this by
encapsulating typical actions into simple script commands that can be easily
invoked from scripts that you write. These commands are collected together
into “modules”. You can see which modules are available, and the commands
that they contain, using the Modules Explorer view. This view is visible in
the top right corner of the Scripting perspective.
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5.1.4 Creating a Python Script

The easiest way to create a Python script is to simply create a text file ending in
“.py” in an existing project. If your scripts will be used with stand-alone Python
programs, you can use PyDev to create a Python project, but in general, any
kind of project will suffice.

For this tutorial, we’re going to use the fern project that has already been
created, and should be visible in the Project Explorer view. You can now
create a Python file in this folder by right clicking on the folder and selecting
New → File from the context menu. This will display the New File dialog as
shown below.

At this point all that remains to be done is enter the name of the file in
the File name: field and click on the Finish button. This will create the file
and automatically open the PyDev editor (assuming you installed PyDev) or
a simple text editor. You should see an editor view something like that shown
below.
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Since the fern project was selected as a scripting location previously, the new
script file should also be visible in the Script Explorer view in the Scripting

perspective. Make sure the Scripting perspective is selected for this view to
be visible.

5.1.5 Writing a Python Script

Our first python script will just print “Hello World” on the console. Enter the
following text in the editor and save the file:

print ’Hello World’

Once you have entered the Python script, is can be easily launched using
the run button (green arrow) on the Script Exporer view. Simply select the
script file you want to run and click on the run button. Any (textual) output
generated by the script will be displayed in the Console view shown below.
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Rather than using the run button, we would like to run this script using our
own button on the Project Explorer view. To do this, add the following lines
to the start of the script, then save the file:

# ********************************************************************

# name : My Script

# toolbar : Project Explorer

# ********************************************************************

As soon as you save the file, you should notice a couple of things. The name
of the script file will change to My Script in the Script Explorer view, and if
you switch to the Project Explorer view, you should see a My Script button
in the view toolbar as shown below.

It is possible to include additional information, including a tooltip popup if
desired:
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# script-type : Python

# description : Start a file browser using current selection.

You can also modify the user interface by changing the button to an icon
and adding a popup conext menu. This is accomplished by adding the following
lines to the script:

# popup : enableFor(org.eclipse.core.resources.IResource)

# image : platform:/plugin/org.eclipse.ui.ide/icons/full/elcl16/configs.png

5.1.6 Interacting with ICE

In order to interact with Java classes in ICE from the Python script, we need to
include additonal modules. In order to load modules, we use the loadModule()

function in Python. The argument to this function is a string representation of
the module path. For this tutorial we will need to load the /System/Platform,
/System/Resources, and /System/UI modules.

In the Modules Explorer view, open the System folder, then drag the
Platform, Resources, and UI items into the script file after the initial com-
ments (you can also type these line in manually if you wish). This should insert
the following lines into your script:

loadModule(’/System/Platform’);

loadModule(’/System/Resources’);

loadModule(’/System/UI’);

Once these module have been loaded, a number of additional functions be-
come available. We want to obtain a reference to the core ICE service, which is
used as the starting point for manipulating ICE models. We also want to obtain
a reference to the fern project. This is done by adding the following lines:

coreService = getService(org.eclipse.ice.core.iCore.ICore)

project = getProject("fern")

Once a reference to the core services has been obtained, we can use this
to obtain a reference to the Reflectivity Model and set some parameters. We
supply the project to the createItem() method so that the generated files will
be saved in the project folder. This is done by adding the following lines:

item = coreService.createItem("Reflectivity Model", project)
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model = coreService.getItem(int(item))

component = model.getComponents().get(0)

entry = component.retrieveAllEntries().get(0)

entry.setValue("waveVector_space.csv")

Note that the createItem() method will return a string representing the
number of that item, so int() is used to convert it to an integer, which is the
argument expected by getItem().

Now the only thing left to do it process the model. This is done using the
core service processItem() as follows:

res = coreService.processItem(model.getId(), "Calculate Reflectivity", 1)

Finally, lets display one of the resulting CSV files if it was successful.

if str(res) == "Processed":

output = getFile("reflectivityModel_%d_rfd.csv" % model.getId())

openEditor(output)

Remember to save the editor using Ctrl/Cmd-S or the File → Save com-
mand from the ICE menu bar before running the script.

5.1.7 Using the Sample Scripts

We have provided a number of sample scripts to show how ICE can be scripted
using EASE. These scripts are located in the org.eclipse.ice.examples.

reflectivity package that is already loaded in your workspace. The scripts
can also be obtained by cloning the ICE Git repository1, then manually import-
ing the org.eclipse.ice.examples.reflectivity package.

There are four sample scripts that demonstrate how a reflectivity model can
be created, configured and executed. The scripts are described in more detail
in the following sections.

createAndProcessPython.py

This is a simple script that demonstrates how to create a reflectivity model and
process the model to obtain a result. The default model inputs are used for the
computation.

1http://github.com/eclipse/ice.git
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# **********************************************************************
# Copyright (c) 2015 UT-Battelle, LLC.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html
#
# Contributors:
# Initial API and implementation and/or initial documentation - Kasper
# Gammeltoft.
#
# This is an example script designed to show how to use ease with ICE. It
# creates a new Reflectivity Model and processes it, using the default mock
# data and inputs.
# **********************************************************************

# Load the Platform module for accessing OSGi services
loadModule(’/System/Platform’)

# Get the core service from ICE for creating and accessing objects.
coreService = getService(org.eclipse.ice.core.iCore.ICore);

# Create the reflectivity model to be used and get its reference. The create item
# method will return a string representing the number of that item, so use int() to
# convert it to an integer.
reflectModel = coreService.getItem(int(coreService.createItem("Reflectivity Model")))

# This is usually where you would do your own customization and automation regarding
# the reflectivity model you just created. Maybe change the layers, or do some custom
# calculations.

# Finally process the model to get the results.
coreService.processItem(reflectModel.getId(), "Calculate Reflectivity", 1);

createAndEditPython.py

This script extends the createAndProcessPython.py script by editing the input
to the model programmatically. The model is then processed to obtain the
results.

# **********************************************************************
# Copyright (c) 2015 UT-Battelle, LLC.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html
#
# Contributors:
# Initial API and implementation and/or initial documentation - Kasper
# Gammeltoft.
#
# This is an example script designed to show how to use ease with ICE. It
# creates a new Reflectivity Model and processes it, but also edits the input
# to the table beforehand.
# **********************************************************************

# Load the Platform module for accessing OSGi services
loadModule(’/System/Platform’)
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# Get the core service from ICE for creating and accessing objects.
coreService = getService(org.eclipse.ice.core.iCore.ICore);

# Create the reflectivity model to be used and get its reference. The create item
# method will return a string representing the number of that item, so use int() to
# convert it to an integer.
reflectModel = coreService.getItem(int(coreService.createItem("Reflectivity Model")))

# Gets the list component used as the data for the table (is on tab 2)
listComp = reflectModel.getComponent(2)

# Gets the third material and sets its thickness to 400
mat1 = listComp.get(2)
mat1.setProperty("Thickness (A)", 400)

# Get the total thickness and set the second material’s thickness to depend
# on the thicknesses of the other materials
totThickness = 0
for i in xrange(0, listComp.size() - 1):

if(i != 1):
totThickness += listComp.get(i).getProperty("Thickness (A)")

# Set the thickness of the second material so that the total sums to 1000 (A)
listComp.get(1).setProperty("Thickness (A)", 1000-totThickness);

# Finally process the model to get the results.
coreService.processItem(reflectModel.getId(), "Calculate Reflectivity", 1);

iterateChangeParameterPython.py

This script demonstrates how to create multiple reflectivity models with varying
input parameters. The models are created and processed sequentially.

# **********************************************************************
# Copyright (c) 2015 UT-Battelle, LLC.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html
#
# Contributors:
# Initial API and implementation and/or initial documentation - Kasper
# Gammeltoft.
#
# This is an example script designed to show how to use ease with ICE. It
# creates several new Reflectivity Models and changes the thickness parameter
# to show the effect that creates.
# **********************************************************************

# Load the Platform module for accessing OSGi services
loadModule(’/System/Platform’)

# Get the core service from ICE for creating and accessing objects.
coreService = getService(org.eclipse.ice.core.iCore.ICore);

# Set a initial value for the thickness of the nickel layer. This will be doubled
# for each iteration to show how this parameter effects the model
nickelThickness = 250;

for i in xrange(1, 5):
# Create the reflectivity model to be used and get its reference. The create item
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# method will return a string representing the number of that item, so use int() to
# convert it to an integer.
reflectModel = coreService.getItem(int(coreService.createItem("Reflectivity Model")))

# Get the nickel layer from the model. It should be in the list, which is component 2,
# and it is the third layer in that list (which is item 2 as the list is zero based).
listComp = reflectModel.getComponent(2);
nickel = listComp.get(2);

nickel.setProperty("Thickness (A)", nickelThickness);

nickelThickness += 250;

# Finally process the model to get the results.
coreService.processItem(reflectModel.getId(), "Calculate Reflectivity", 1);

listFromScratchPython.py

This script demonstrates how to create a reflectivity model and programmably
create and set up the layers in the model. The model is then process to obtain
the results.

# **********************************************************************
# Copyright (c) 2015 UT-Battelle, LLC.
# All rights reserved. This program and the accompanying materials
# are made available under the terms of the Eclipse Public License v1.0
# which accompanies this distribution, and is available at
# http://www.eclipse.org/legal/epl-v10.html
#
# Contributors:
# Initial API and implementation and/or initial documentation - Kasper
# Gammeltoft.
#
# This is an example script designed to show how to use ease with ICE. It
# creates a new Reflectivity Model and shows how to customize and build up
# the layers in the model from scratch.
# **********************************************************************

# Needed imports from ICE
from org.eclipse.ice.datastructures.form import Material

# Load the Platform module for accessing OSGi services
loadModule(’/System/Platform’)

# Get the core service from ICE for creating and accessing objects.
coreService = getService(org.eclipse.ice.core.iCore.ICore);

# Create the reflectivity model to be used and get its reference. The create item
# method will return a string representing the number of that item, so use int() to
# convert it to an integer.
reflectModel = coreService.getItem(int(coreService.createItem("Reflectivity Model")))

# Gets the list component used as the data for the table (is on tab 2)
listComp = reflectModel.getComponent(2)

# Now we want to build up the list from our own data, so we can do that here.

# The first step would be to clear the list so that we can start adding to it. Clearing
# the list requires the locks as multiple operations are happening and we need to
# protect the list from multiple threads trying to access it at the same time.
listComp.getReadWriteLock().writeLock().lock()
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listComp.clear()
listComp.getReadWriteLock().writeLock().unlock()

# Create the layer of air
air = Material()
air.setName("Air")
air.setProperty("Material ID", 1)
air.setProperty("Thickness (A)", 200)
air.setProperty("Roughness (A)", 0)
air.setProperty(Material.SCAT_LENGTH_DENSITY, 0)
air.setProperty(Material.MASS_ABS_COHERENT, 0)
air.setProperty(Material.MASS_ABS_INCOHERENT, 0)

# Create the Aluminum Oxide layer
AlOx = Material()
AlOx.setName("AlOx")
AlOx.setProperty("Material ID", 2)
AlOx.setProperty("Thickness (A)", 25)
AlOx.setProperty("Roughness (A)", 10.2)
AlOx.setProperty(Material.SCAT_LENGTH_DENSITY, 1.436e-6)
AlOx.setProperty(Material.MASS_ABS_COHERENT, 6.125e-11)
AlOx.setProperty(Material.MASS_ABS_INCOHERENT, 4.47e-12)

# Create the Aluminum layer
Al = Material()
Al.setName("Al")
Al.setProperty("Material ID", 3)
Al.setProperty("Thickness (A)", 500)
Al.setProperty("Roughness (A)", 11.4)
Al.setProperty(Material.SCAT_LENGTH_DENSITY, 2.078e-6)
Al.setProperty(Material.MASS_ABS_COHERENT, 2.87e-13)
Al.setProperty(Material.MASS_ABS_INCOHERENT, 1.83e-12)

# Create the Aluminum Silicate layer
AlSiOx = Material()
AlSiOx.setName("AlSiOx")
AlSiOx.setProperty("Material ID", 4)
AlSiOx.setProperty("Thickness (A)", 10)
AlSiOx.setProperty("Roughness (A)", 17.2)
AlSiOx.setProperty(Material.SCAT_LENGTH_DENSITY, 1.489e-6)
AlSiOx.setProperty(Material.MASS_ABS_COHERENT, 8.609e-9)
AlSiOx.setProperty(Material.MASS_ABS_INCOHERENT, 6.307e-10)

# Create the Silicon layer
Si = Material()
Si.setName("Si")
Si.setProperty("Material ID", 5)
Si.setProperty("Thickness (A)", 100)
Si.setProperty("Roughness (A)", 17.5)
Si.setProperty(Material.SCAT_LENGTH_DENSITY, 2.07e-6)
Si.setProperty(Material.MASS_ABS_COHERENT, 4.7498e-11)
Si.setProperty(Material.MASS_ABS_INCOHERENT, 1.9977e-12)

# Add all of the materials back to the list (in top to bottom order)
listComp.getReadWriteLock().writeLock().lock()
listComp.add(air);
listComp.add(AlOx);
listComp.add(Al);
listComp.add(AlSiOx);
listComp.add(Si);
listComp.getReadWriteLock().writeLock().unlock()

# Finally process the model to get the results.
coreService.processItem(reflectModel.getId(), "Calculate Reflectivity", 1);
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5.2 Dynamic UI

This tutorial will show you how to create custom, dynamic UI extensions to
Eclipse ICE.

What you will need for this tutorial:

• Experience creating Eclipse plugins

• Experience writing UI code with SWT

• Experience creating an ICE Item

5.2.1 Introduction

ICE makes some educated guesses based on the type of your components and
information that it can glean from your data to figure out the best way that it
can generate the the UI. However, after you create your first set of Items, you
might find yourself wondering if you can change the way that ICE auto-generates
the UI to better fit your needs. ICE lets you do this by setting the Context
of your Form and Components with the setContext() operation. Setting the
context with a string that is unique to your project will let ICE look up UI
extensions that you create and publish through the Eclipse 4 framework.

There are several important things to consider before you start extending the
UI. First, how much work do you want to do? Some of the UI constructs in ICE
are quick to change, such as EntryComposites for showing Entries, but others,
like GeometryPage and MeshPage, could require significant work because of the
level of graphics involved.

This tutorial will show you how to change two pieces of ICEs UI: The page
for showing GeometryComponents and an EntryComposite. We will only show
you how to change the GeometryPage, not how to actually generate new 3D
graphics. The source code for this tutorial is in the ICE repo in a project called
org.eclipse.ice.demo.

5.2.2 Create an ICE Item Project

Use the ICE Item Project Generation Wizard to create a new Item with a
GeometryComponent and a DataComponent with one Entry in the Form. You
can copy the following code into your setupForm() operation:

@Override
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public void setupForm() {
form = new Form();

ioService = getIOService();

// Create a geometry component
GeometryComponent geomComp = new GeometryComponent();
geomComp.setName("Geometry");
geomComp.setDescription("A geometry");
geomComp.setContext("demo-geometry");
geomComp.setGeometry(

new ShapeController(new Shape(), new BasicView()));

// Create a data component
DataComponent dataComp = new DataComponent();
dataComp.setName("Data");
dataComp.setDescription("Some Data");
dataComp.setContext("demo");
// Need to set the id since geomComp is number 1
dataComp.setId(2);

// Create an Entry for the data component
IEntry entry = new StringEntry();
entry.setName("Data Entry");
entry.setDescription("An Entry with Important Data");
entry.setContext("demo-entry");
// Add the Entry to the data component
dataComp.addEntry(entry);

// Add both components to the Form, showing the data component first.
form.addComponent(dataComp);
form.addComponent(geomComp);

// Set the context on the Form
form.setContext("demo");

return;
}

Note that your import packages lines should look this the following:

import org.eclipse.core.resources.IFile;
import org.eclipse.core.resources.IProject;
import org.eclipse.core.runtime.CoreException;
import org.eclipse.eavp.viz.service.modeling.AbstractView;
import org.eclipse.eavp.viz.service.modeling.ShapeController;
import org.eclipse.eavp.viz.service.modeling.ShapeMesh;
import org.eclipse.ice.datastructures.entry.IEntry;
import org.eclipse.ice.datastructures.entry.StringEntry;
import org.eclipse.ice.datastructures.form.DataComponent;
import org.eclipse.ice.datastructures.form.Form;
import org.eclipse.ice.datastructures.form.FormStatus;
import org.eclipse.ice.datastructures.form.GeometryComponent;
import org.eclipse.ice.io.serializable.IIOService;
import org.eclipse.ice.io.serializable.IReader;
import org.eclipse.ice.io.serializable.IWriter;
import org.eclipse.ice.item.model.Model;

You may need to add some of these packages to your Manifest file.

If you have not created an Item in ICE before, please see the ICE Item

Generation tutorial to do this.
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Add this plugin to the launch configuration for your system, launch ICE
and make sure that you can successfully create a DemoModel Item. You should
have see a Form with two pages as in figures 5.1 and 5.2.

Figure 5.1: Default Entry Composite on a Form

The rest of the tutorial will look at replacing the routine that draws the
Entry on the first page and the entire Geometry Page with your own custom
page. You wont have to make any additional changes to your Item (assuming
it works as shown above). Note that in the code above we need to use different
context names for the Entry and the GeometryComponent so that the context
can uniquely identify the routines that draw each.

5.2.3 Create an IPageProvider and IPageFactory

We will replace the Geometry Page first. Create a new package.This requires
two pieces to properly locate your Page, through your IPageFactory, and to
draw your Page, through you IPageProvider.

Start by adding the following packages to your import packages block in
your Manifest file:

• org.eclipse.ice.client.widgets.providers

• org.eclipse.ice.client.widgets.providers.Default

• org.eclipse.ui.forms
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Figure 5.2: Default Geometry Page

• org.eclipse.ui.forms.editor

• org.eclipse.ui.forms.widgets

• org.eclipse.e4.core.contexts

• org.eclipse.e4.core.di

• org.eclipse.e4.ui.model.application

• org.eclipse.e4.ui.model.application.ui

Create a class that implements IPageProvider and copy the following code
into it:

public class DemoGeometryPageProvider implements IPageProvider {

@Override
public String getName() {

// TODO Auto-generated method stub
return "demo";

}

@Override
public ArrayList<IFormPage> getPages(FormEditor formEditor,

ArrayList<Component> components) {

ArrayList<IFormPage> pages = new ArrayList<IFormPage>();
// Get the GeometryComponent and create the GeometryPage.
if (!(components.isEmpty())) {

GeometryComponent geometryComponent = (GeometryComponent) (components
.get(0));

if (geometryComponent != null) {
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// Make the GeometryPage
DemoGeometryPage geometryPage = new DemoGeometryPage(formEditor,

"GPid", geometryComponent.getName());

// No need to set the geometry component for the demo, but
// something like would be necessary in a real application.
// geometryPage.setGeometry(geometryComponent);

// Add the page
pages.add(geometryPage);

}

}

return pages;
}

}

This class will provide your page to the platform. We need a second class
that actually draws the content on the Geometry page. We will create a third
class here, for convenience, that inherits from ICEs ICEFormPage base class to
act as the GeometryPage. We dont actually need to show the content of the
Geometry component for now because we just want to show that we can change
the page. So, create your class and copy the following code into it to just show
a label in place of the original 3D editor:

public class DemoGeometryPage extends ICEFormPage {

public DemoGeometryPage(FormEditor editor, String id, String title) {
super(editor, id, title);
// TODO Auto-generated constructor stub

}

/**
* <p>
* Provides the page with the geometryApplication’s information to display
* geometry.
* </p>
*
* @param managedForm
* the managed form that handles the page
*/
@Override
public void createFormContent(IManagedForm managedForm) {

// Local Declarations
final ScrolledForm form = managedForm.getForm();
GridLayout layout = new GridLayout();

// Setup the layout and layout data
layout.numColumns = 1;
form.getBody().setLayoutData(

new GridData(SWT.FILL, SWT.FILL, true, true, 1, 1));
form.getBody().setLayout(new FillLayout());

// Just create some text and say hello
Label geometryText = new Label(form.getBody(), SWT.FLAT);
geometryText.setText("Draw something based on the geometry.");

return;
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}

}

5.2.4 Create a new IEntryComposite

Individual Entrys that ICE draws can be extended in the same way. First,
create a subclass of AbstractEntryComposite that implements render and copy
the following code into it:

public class DemoEntryComposite extends AbstractEntryComposite {

public DemoEntryComposite(Composite parent, IEntry refEntry, int style) {
super(parent, refEntry, style);

}

@Override
public void render() {

Button button = new Button(this, SWT.PUSH);
button.setText("My button");

Label label = new Label(this, SWT.FLAT);
label.setText(super.getEntry().getValue() + " in new Entry widget.");
setLayout(new FillLayout());
this.layout();

return;
}

}

Next, create a provider to publish your Entry Composite to the platform
and copy the following code into it:

public class DemoEntryCompositeProvider implements IEntryCompositeProvider {

@Override
public String getName() {

// TODO Auto-generated method stub
return "demo-entry";

}

@Override
public IEntryComposite getEntryComposite(Composite parent, IEntry entry,

int style, FormToolkit toolKit) {
// TODO Auto-generated method stub
return new DemoEntryComposite(parent, entry, style);

}

}
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5.2.5 Publishing through the e4 extension point

The most common way to publish these extensions to the platform is to create
an extension at the org.eclipse.e4.workbench.model extension point. You can
do this by creating an executable processor. Create a new class and add the
following code:

public class DemoWidgetsProcessor {

/**
* This operation executes the instructions required to register the demo
* widgets with the e4 workbench.
*
* @param context
* The e4 context
* @param app
* the model application
*/
@Execute
public void execute(IEclipseContext context, MApplication app) {

// Add the geometry provider
IPageProvider provider = ContextInjectionFactory

.make(DemoGeometryPageProvider.class, context);
context.set("demo-geometry", provider);

// Add the EntryComposite provider
IEntryCompositeProvider compProvider = ContextInjectionFactory

.make(DemoEntryCompositeProvider.class, context);
context.set("demo-entry", compProvider);

}

}

Next, either create an extension point graphically or add the following code
to your plugin.xml file:

<extension
id="org.eclipse.ice.demo.ui.processor"
name="ICE Demo UI Processor"
point="org.eclipse.e4.workbench.model">

<processor
apply="always"
beforefragment="true"
class="org.eclipse.ice.demo.ui.DemoWidgetsProcessor">

</processor>
</extension>

Your extensions will now be available in the workbench. Your entry com-
posite is should look like fig. 5.3.

You geometry component should look like fig. 5.4.
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Figure 5.3: Updated Entry Widget

5.2.6 Publishing through Context Functions

Make sure to check Activate this plug-in when one of its classes loaded.

in your MANIFEST.mf file.

You can alternatively publish your new extensions to the OSGI framework
so that they can be dynamically injected into the ICE’s UI code. These ex-
tensions are registered as standalone services that are dynamically located at
runtime based on the context name that you specified in your data structures.
The benefit of this method over the extension point is that it can be used to
dynamically update based on the present context of the UI, not the initial con-
text. This means that in addition to the type of data structure involved the UI
can be tailored based on the particular area of the workbench where it would
be drawn and the current runtime state.

Create a new context function for your IEntryComposite. You should create
a subclass of ContextFunction with the following code:

public class DemoEntryCompositeContextFunction extends ContextFunction {

@Override
public Object compute(IEclipseContext context, String contextKey) {

IEntryCompositeProvider provider = ContextInjectionFactory
.make(DemoEntryCompositeProvider.class, context);

// add the new object to the application context
MApplication application = context.get(MApplication.class);
IEclipseContext ctx = application.getContext();
ctx.set(IEntryCompositeProvider.class, provider);
return provider;

}
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Figure 5.4: The updated Geometry page.

}

Create an OSGI component with the following contents:

<?xml version="1.0" encoding="UTF-8"?>
<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0"
name="org.eclipse.ice.demo.entry"> <implementation

class="org.ecli pse.ice.demo.ui.DemoEntryCompositeContextFunction"/>
<property name="service.context.key" type="String" value="demo-entry"/>
<service> <provide
interface="org.eclipse.e4.core.contexts.IContextFunction"/> </service>

</scr:component>

Now, create a context function for your Geometry Page. You should create
a subclass of ContextFunction with the following code:

public class DemoGeometryPageContextFunction extends ContextFunction {

@Override
public Object compute(IEclipseContext context, String contextKey) {

IPageProvider provider = ContextInjectionFactory
.make(DemoGeometryPageProvider.class, context);

// add the new object to the application context
MApplication application = context.get(MApplication.class);
IEclipseContext ctx = application.getContext();
ctx.set(IPageProvider.class, provider);
return provider;

}

}
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and an OSGI component with the following contents:

<?xml version="1.0" encoding="UTF-8"?>
<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0"
name="org.eclipse.ice.demo.geometry.page"> <implementation
class="org.eclipse.ice.demo.ui.DemoGeometryPageContextFunction"/> <property
name="service.context.key" type="String" value="demo-geometry"/> <service>

<provide interface="org.eclipse.e4.core.contexts.IContextFunction"/>
</service>

</scr:component>

5.2.7 Replacing the whole Page Factory

If you want to replace the way that all pages in ICE are drawn, you can replace
the entire Page Factory. Create a new class in your package that inherits from
DefaultPageFactory, which will save you some work over implementing an entire
new factory from scratch. See fig. 5.5.

Copy the following code into your new subclass:

public class DemoGeometryPageFactory extends DefaultPageFactory {

@Override
public ArrayList<IFormPage> getGeometryComponentPages(FormEditor editor,

ArrayList<Component> components) {
DemoGeometryPageProvider pageProvider = new DemoGeometryPageProvider();
return pageProvider.getPages(editor, components);

}
}

This will now build on your previous DemoGeometryPageProvider to provide
it to the framework through a factory. You can override other operations to
provide access to other custom pages. This method may be more efficient than
creating separate page extension for each page type. To publish this to the
platform, create a Context Function with the following code:

public class DemoGeometryPageFactoryContextFunction extends ContextFunction {

@Override
public Object compute(IEclipseContext context, String contextKey) {

IPageFactory factory = ContextInjectionFactory
.make(DemoGeometryPageFactory.class, context);

// add the new object to the application context
MApplication application = context.get(MApplication.class);
IEclipseContext ctx = application.getContext();
ctx.set(IPageFactory.class, factory);
return factory;

}

}

Your OSGI component should be published as such:
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Figure 5.5: Generating the Page Factory class.

<?xml version="1.0" encoding="UTF-8"?>
<scr:component xmlns:scr="http://www.osgi.org/xmlns/scr/v1.1.0"
name="org.eclipse.ice.demo.factory"> <implementation
class="org.eclipse.ice.demo.ui.DemoGeometryPageFactoryContextFunction"/>
<property name="service.context.key" type="String" value="demo"/> <service>

<provide interface="org.eclipse.e4.core.contexts.IContextFunction"/>
</service>

</scr:component>

and your MANIFEST.mf file should contain:

Service-Component: OSGI-INF/*.xml
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Module 6

Wrap-Up
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